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THE Most Important Piece of Tuning You
Can Do For Your PC?
Windows XP wastes a lot of processing power anticipating
which files the user will require next and accessing them.
This process is known as Prefetch. An analogy might be
your dog ‘fetching’ his ball for you, before you have even
thrown it. Microsoft intends that this operation will speed
up your computing experience. In many situations this
may be the case. However, it can sometimes have the
opposite effect, clogging up your PC with temporary files
and actions that actually slow things down.  After reading
this article you will be able to: 

Dr Steve North is a computer science expert who has
worked consistently with Microsoft Windows for over a
decade. As a commercial researcher and developer, his
clients have included Intel and Lloyds of London. He is an
accomplished academic with international publications and
postgraduate lecturing experience. Steve also worked as a
consulting researcher for NASA’s Goddard Space Flight
Center.

Dr Steve North:
“Sometimes the

smallest of
adjustments can

make a great
deal of difference

to the speed of
Windows XP. This

is particularly
true if you are
using an older 

or lower
specification PC.”

X 25/2
X 25/2

X 25/3
X 25/4

X 25/5

X 25/7

X 25/9

• Stop your PC from preparing to access files 
that you never use! ..............................................

• Find unwanted Prefetch files .................................
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When you startup
your PC or run a
program, Prefetch
is making decisions
that may impact
the speed of
Windows XP.

This is a Prefetch
file for Microsoft
Internet Explorer.


!?

Stop Your PC from Preparing to Access Files
that You Never Use!
Prefetch is designed to speed up your PC’s performance in
two ways. Firstly, XP recognises the files that it most
commonly requires at Startup. Secondly, it remembers the
files required to run the programs that each user accesses
most frequently (Microsoft Word, for example). 
Prefetch then uses this information in two ways. It creates a
temporary file for each program, containing a list of all
resources (images, data files, etc.) required to run it. These
are then loaded in advance so that the program will start
more rapidly when required. In addition, Prefetch instructs
XP’s Disk Defragmenter to change where software tools are
stored on the hard drive, so that frequently accessed tools are
closer together. This prevents the hard drive heads from
having to scoot all over the disk and therefore improves XP
performance.

Find Unwanted Prefetch Files 
To get started you will need to know where to look for the
Prefetch files on your PC.

1. Open Windows Explorer by right-clicking Start and
selecting Explore from the menu.

2. Navigate to C:\WINDOWS\Prefetch

You’ll notice that some of the files contained in this folder
refer to familiar software programs. For example:
IEXPLORE.EXE-27122324.pf.

!?
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Clean Out Unnecessary Files that are Slowing
Down Your PC

The Windows Prefetch folder

You will probably be aware that your PC’s TEMP folder and
cached temporary Internet files need cleaning out
periodically to keep Windows running efficiently. In the
same way, your Prefetch folder can become clogged with
references to software that you once accessed frequently, but
no longer use on a regular basis. This may be slowing down
your PC. I would recommend that you delete the entire
contents of this folder (don’t worry, any beneficial files will
be regenerated when you next restart). This should be done
on a monthly basis. Alternatively, you could choose to just
delete any files that relate to tools that you no longer use
frequently.

1. To delete all of these files select Edit > Select All.
2. Press to delete all of these files.Delete

Prefetch files 
end with the
extension .pf

Prefetch files are
binary and cannot

be read in a text
file reader such as

Notepad.


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The ‘/q’ in the text
file just stops the
Command Prompt
from asking you to
confirm deletion
for each of the
Prefetch files.



Automate the Emptying of Your Prefetch
Folder 
The first method allows you to empty your Prefetch folder
with just one click from the Windows Desktop.
Steps 1-3 are to make sure that your file extensions are
visible. It is recommended that you retain this setting for
security reasons. 
1. Open Windows Explorer by right-clicking Start and

selecting Explore from the menu.
2. Tools menu > Folder Options > View tab > Hide

extensions for known file types should be ticked. 
3. Still under View tab > Folder views > click Apply to

All Folders > click OK.
4. Right-click on your Desktop and select New and then

Text Document.
5. Open ‘NEW TEXT DOCUMENT.TXT’ on your Desktop.
6. Type:

del c:\WINDOWS\Prefetch\*.*/q
into the text file and then save it. Note: change ‘c’ to
the correct drive letter if this is not the drive that you
have Windows installed on. Close the file.

7. Right-click on NEW TEXT DOCUMENT.TXT and
rename it  CLEAR_PREFETCH.BAT (or any name
ending in .BAT).

8. When you want to empty your Prefetch folder (at least
once a month) double-click on
C L E A R _ P R E F E T C H . BAT (a Command Prompt window
may open asking you to confirm. If so, type ) .

That should have made things a little less labour intensive.
Now, you will find out how to take it one stage further.
Automatically delete Prefetch files monthly or on Windows
Startup:

Y

!?
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1. Click Start > All Programs > Accessories > System
Tools > Scheduled Tasks.

2. Double-click Add Scheduled Task.
3. In the Scheduled Task Wizard click Next > Browse

and find Clear_Prefetch.bat on your Windows
Desktop.

4. Select to perform this task either Monthly or When
my computer starts, as preferred.

5. Click Next, and enter a time for the task to be
performed. Click Next > Next > Finish and restart
your PC.

In Windows XP (Professional) it is also possible to automate
Prefetch by clicking Start > Run. Type gpedit.msc . This is
not available in Windows XP (Home).

Modify Prefetch Registry Settings for Faster
Performance
Now that you know how to perform Prefetch housekeeping,
you might want to consider whether it is worth having
Prefetch switched on at all. Prefetch can be disabled or
modified just by changing one registry value:
EnablePrefetcher. As a starting point, your options for this
setting should depend on the amount of RAM that your PC
is equipped with. If your PC has less than 128 MB,
EnablePrefetcher should be set to 0. A PC with more than
512 MB is likely to perform better with a setting of 3. These
are just guidelines and you may want to experiment with
different values. You will need to restart Windows before
any performance difference will be noticed. 
As always, making changes to the registry could stop
Windows from working. You are advised to set a System
Restore point and backup the registry before you make
any changes.

!

!?


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Make sure that
the base setting
remains on
‘ H e x a d e c i m a l ’.

Change the value
in the Value Data
f i e l d .

The status bar at
the bottom of
the Registry
Editor shows your
location within
the registry.



It is important to note that there are several related registry
keys with very similar names. Before changing any values,
please make absolutely sure that the key name contains:
CurrentControlSet.
1. Click Start > Run.
2. Type regedit and press or click OK.
3. Locate and open the following registry key:

HKEY_LOCAL_MACHINE\SYSTEM\
CurrentControlSet\Control\SessionManager\
MemoryManagement\PrefetchParameters

4. Right-click on EnablePrefetcher and choose Modify.
5. In the Value Data field of the Edit DWORD Value

box you will see a number. You can amend the
number in this field with reference to the following
table:

Using Registry Editor’s DWORD Value box
to edit EnablePrefetcher

Enter

Value Result
0 Disable (no Prefetch at all).
1 Application Launch Prefetch (when programs are started).
2 Boot Prefetch (to speed up Windows at Startup).
3 Prefetch everything.
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Use Third Party Software for Tweaking
Prefetch
If you’d rather not modify the registry there are several
software tools available to help with the optimisation of
Prefetch.  All of the software mentioned in this article is on
the CD that accompanies this update. Here is a quick
summary of the features provided by each of the three third
party tools:

Universal Tweaker
Universal Tweaker is a Command Prompt-based tool that,
along with other optimisation tasks, automates the process
of emptying your Prefetch folder. Once you have entered the
details of the your PC, this tool immediately makes the
necessary system changes. 
Note: if you are using Sophos anti-virus software, you may
find that you need to temporarily disable Sophos’ Intercheck
as follows:
1. Click Start> All Programs> Sophos Anti-virus>

Sophos Anti-virus tool.
2. Select the IC Client tab.
3. Click the large red Stop button at top left.

You should restart Intercheck (same as above but click Start)
as soon as you have downloaded or finished working with
Universal Tweaker.

Optimise Prefetch
with these

software tools.

Software that
makes low-level

adjustments may
be mistaken 
for a virus.



Yes  No Test
✔

✔
✔
✔

Prefetch tool Changes
registry? 

Cleans out
files?

Schedules automated
optimisation?

Prefetch Clean
And Control

Yes Yes No

Universal
Tweaker

No Yes No

Ace Utilities No Yes No

!?
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The Prefetch
features in Ace
Utilities can be
found under
Erase Your
History.





Ace Utilities
Ace Utilities is another all round system-tweaker that offers
scheduled Prefetch cleaning as one of its options. After
downloading and installing Ace Utilities follow the
instructions below to use this feature:
1. Select Erase Your History, and open the Windows

tab.
2. Select Empty the Windows XP Prefetch Folder and

then click Execute Now.

The main window in Ace Utilities

Prefetch Clean And Control
This is a tool that allows you to both modify the Prefetch
registry settings (as described earlier) and also to empty your
Prefetch folder.
To empty the Prefetch folder:
1. Click on the Clean Prefetch Folder Now button.
To adjust the Prefetch registry settings:
1. Choose one of the following Control Prefetch

Settings radio-buttons: Disable Prefetch, Monitor
Application Launch Only, Monitor Boot File Launch
Only or Monitor Application And Boot File Launch.
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2. Prefetch Clean And Control will indicate which of the
buttons it thinks is the best option for your current
system.

3. Click on the Set Prefetch Parameters button.

The interface for Prefetch Clean And Control

Windows XP Services – Required Settings for
Prefetch  
We’re nearly there now! There is just one thing that might
stop Prefetch from working, irrespective of any other
settings. Many of the Prefetch options (with the exception of
monitoring the launch of software programs) depend on
Windows XP’s built-in scheduling functionality. To check
that Prefetch is going to work at the scheduled times,
proceed as follows:
1. Click Start > Control Panel.
2. Open Administrative Tools, then select Services.
3. In the right-hand pane check that the following two

services are indicated as Started in the status
column: COM+ Event System and Task Scheduler.

4. If one or both of the services has not started, select
each service name by clicking on it. 

It is important to
note that the S e t

P r e f e t c h
Pa r a m e t e r s

button in
Prefetch Clean
And Control is

not for refining
s e t t i n g s, it

actually applies
any modifications

that you have
m a d e .

Prefetch may not
work at if certain

Windows XP
services are

disabled.



!?
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This is where you
will find the
services COM+
Event System and
Task Scheduler.

1.
2.
3.
4.
5.

5. Click on Restart the service.
6. Right-click on the service name and select

Properties.
7. Select the General tab.
8. Set the Startup type drop-down menu to Automatic.

The Windows XP Component Services window

This article has introduced you to a hidden element of
Windows XP functionality: Prefetch. This process can have
a dramatic impact on the speed of your PC. Prefetch is a
well-intentioned process that can be very helpful. It can also
add to the time that you spend watching the Windows egg
timer. Having followed the suggestions in this article, you
are now in a position to decide on the best strategy to keep
Windows running at the fastest possible speed on your
hardware. You might choose to manually delete Prefetch
files on a regular basis. Alternatively, you may decide that
automating the process is sensible. If you happen to have an
older computer, you may even come to the conclusion that
Prefetch should be completely disabled. This article has
helped you to better understand one of Windows XP’s many
mysteries. You are now armed with the necessary skills to
understand and configure Prefetch on your PC.


