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Streamlining Your Windows Experience

Your Windows system may have been functioning perfectly for months when
suddenly an irritating little problem manifests itself. It might not prevent you
from using your system but it’s annoying all the same. Using the advice in this
article you will be able to identify these problems and fix them, streamlining
your Windows experience and making you more productive.

Stefan Zasada:
“Windows works perfectly most of the time, but occasionally little problems surface
which you don’t have a clue how to fix. The information in this article can help you
solve many of these tricky little bugs.”
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With the information in this article you can:
• Solve the most common Windows errors that people often

overlook
• Use hidden tools to sweep all the glitches from your PC
• Get your system running at tip-top performance
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Identify your
problem at a
glance.

An End to Windows Problems
There are many small problems that can occur when using
Windows that have no obvious cause. The problem might
not make your system unusable, but getting rid of it is still
a priority. The advice in this article will tell you how to solve
many of these common problems. Use the following table to
identify your problem and look up a full description of the
solution in the following pages.

!?

Error in Description Solution Page
Windows
Setup

Windows components
are missing.

Re-install the Windows
component via Add/Remove
Programs in the Control Panel.

S 22/3

Windows
Desktop

Desktop icons
arranged incorrectly.

If the icons won’t let themselves
be arranged, you can switch off
automatic arranging.

S 22/4

Fonts Fonts are missing or
symbols from fonts
are missing. 

Fonts have been installed
incorrectly. Re-install fonts in
the correct way, and ensure that
the printer driver is installed
properly.

S 22/6

DVD
Player

Unable to watch
DVDs with Media
Player.

Adjust settings in the registry to
take advantage of Media Player’s
hidden DVD playback features.

S 22/8

Windows
Startup

Windows has
problems with the
programs it loads
during startup.

Use Autoruns or Absolute
Startup, advanced management
tools included on the CD with
this update, to control what
programs are run by Windows at
startup.

S 22/9
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Fix Missing Windows Components
If Windows games or important system programs are
missing from your computer, for example Microsoft Paint is
not available, then Windows itself is not faulty but the
relevant component was not installed. You can manage
which parts of the Windows system are installed by
following these instructions:
1. Go to Start > Settings > Control Panel (Start >

Control Panel in Windows XP).
2. Double-click on Add/Remove Programs (Add or

Remove Programs in Windows XP).
3. Select Windows Setup (98/Me) or Add/Remove

Windows Components (2000/XP).
You can now activate the missing parts of your Windows
system. You may be asked to insert your original Windows
installation CD. You can also use this to remove the
Windows components you find useless, for example if you
never play the Windows games you can get rid of them.

Add missing
Windows

components using
the Control Panel.

Remove Windows
components you

don’t use.



!?

Error in Description Solution Page

Windows
Update

Error with a
download or
installation.

Activate the Cryptographic
Service in the Control Panel.

S 22/11

Windows
System
Files

Your computer
continually crashes. 

Use Windows built-in repair
tools to identify faulty files and
replace them.

S 22/11

Windows
Device
Drivers

Device drivers have
become corrupt.

Use Windows built-in tools to
check the integrity of your
device drivers.

S 22/12
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You can 
choose which 
sub-components
to install by
double-clicking
on each
component.

Click OK when
you’ve finished.

!?

Adding Windows components in Me

Fix Misbehaving Desktop Icons
You may sometimes find you’ve spent ages arranging the
icons on your desktop only to find they’re all over the place
the next time you turn your computer on. Sometimes the
icons may even spring back to their original position when
you try to move them. Below are some common solutions to
these problems:
• If the icons are automatically ordered on the left-hand

side of the screen and don’t stay in their desired
position then ‘Auto Arrange’ is activated on your
desktop. Right-click on an empty part of the desktop,
from the popup menu go to Arrange Icons and
deselect Auto Arrange.
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• If you’ve positioned the icons on your desktop manually,
you can neaten up the layout by aligning the icons to
a grid. Windows XP users right-click on an empty
area of your desktop, select Arrange Icons > Align to
Grid. Windows 95/98/Me/2000 users, right-click on an
empty area of the desktop and select Line Up Icons.

The new Start Menu is activated be default in Windows XP.
This means that My Computer, My Documents and My
Network Places are not shown on the desktop. You can
reinstate these icons by following these steps:
1. Right-click on an empty area of the desktop and

select Properties.
2. Click on the Desktop tab, then click on the

Customize Desktop button.
3. Click on the General tab and in the Desktop icons

section place a tick next to the icons you want
visible on your desktop.

4. Click OK then OK again.
If none of these steps let you see your icons in the way you
want, then it is possible a Windows file has become
damaged. Luckily you can cure this by following these steps:

Windows XP
1. Navigate to: 

C:\Documents and Settings\username\Local
Settings\Application Data 
Where username is your Windows login.

2. Rename the file IconCache.db to IconCache.old

Windows 98/Me/2000
1. Open C:\Windows (C:\WINNT in Windows 2000).
2. Rename the file ShellIconCache to

ShellIconCache.old

You can control
exactly where

icons are
positioned on your

desktop.

Windows XP 
only tip.

If all else fails …

... delete the 
icon cache.




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See the hidden
files.

Make sure you
install new fonts
correctly.

!


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Now re-boot your computer. When Windows finds that the
file is missing it will build a new, uncorrupted copy. Note,
the IconCache.db may not be visible. If this is the case select
Tools > Folder Options, click the View tab and select Show
hidden files and folders. Click OK.

Fonts: Problems and Solutions 
Windows saves all of its fonts in the folder
C:\Windows\Fonts (C:\Winnt\Fonts in Windows 2000). This
is automatically loaded up each time Windows starts and is
kept permanently in your PC’s memory. Even when the file
size of an individual font seems small you should not keep
more than 1000 fonts on your system, because the Windows
registry cannot cope with more than 1000 entries.

Correctly installing fonts
Many users try to install new fonts by copying them directly
into the Fonts folder. However this is not the correct way of
installing fonts and means that applications such as Word
will not be able to use them. To correctly install a font:
1. Select Start > Settings > Control Panel (Start >

Control Panel in XP).
2. Double-click on Fonts (This may not be available if

you’re in Category View on Windows XP).
3. Select File > Install New Font…
4. Select the font file that you want to install and click

OK.
You can remove fonts by deleting them from the Fonts folder
in the Control Panel just as you would a normal file. Be
careful not to delete any files that end .FON as these are
essential Windows system fonts, although some TrueType
fonts (ending in .TTF) are also required by Windows.
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Problem: Only a few fonts are available
If, for example, you are writing a letter in Word and you find
that none or only a few fonts are available instead of all the
fonts you expected, this could be caused by a problem with
your printer driver.
You can fix this by this by installing the correct printer
driver:
1. Open the Control Panel as described in step 1 on the

previous page.
2. Double-click on Printers (Printers and Faxes in

Windows XP).
3. Right-click on your printer and select Properties,

then click on the Advanced tab (Details in 98/Me).
4. Click on New Driver and select the correct driver

from the list.
Alternatively you can re-install the printer driver from the
manufacturer’s CD that came with your printer.

Font management tools
On the CD that accompanies this update, you will find a link
to a handy tool called The Font Thing which you can use to
simplify the installation and removal of fonts, along with
viewing examples of what the font looks like and lots of
other data about it. Take control of your fonts today.

Use The Font Thing to manage your fonts

If you find that
none of your fonts
are available help

is at hand.  

Font management
software is

available on this
update’s CD.

Uninstall your
fonts with 

this button.

Preview fonts in
this window.


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Software available
on the CD that
accompanies this
update.

Unlock Media
Player’s hidden
features.

Ensure your
computer has
hardware based
support for DVD
playback.

Windows 98 users
need to install an
MPEG-2 codec.



Take Control of Your CD and DVD Drives
A CD-ROM drive is an indispensable part of your computer’s
hardware setup, and many new machines will also come
with a DVD drive. Here are some handy tips to get the most
from them.

Play DVDs using Media Player
Many new computers come with a DVD drive, but not all
have DVD playing software included. Fortunately with a
small registry tweak Windows Media Player will play DVDs.
A link to version 9 of Media Player is available on the CD
accompanying this update. To be able to watch DVDs:
1. Start the Registry Editor by clicking Start > Run,

typing REGEDIT and clicking OK.
2. Locate the registry key:

HKEY_CURRENT_USER\Software\Microsoft\
MediaPlayer\Player\Settings

3. Right-click in the right-hand panel and choose New
> String Value from the pop-up menu.

4. Enter EnableDVDUI as the name of the new string
value.

5. Double-click on your new String value and give it a
value data of ‘Yes’.

6. To start playing DVDs select File > Open. In the Files
of type dialogue box you can now choose to open
DVDs.

In Windows 98 you may need to install an MPEG-2 codec
for this to work. An MPEG-2 codec is available on the CD
accompanying this update.

Change your CD-ROM drive letter
If you want to change the drive lettering after installing a
DVD/CD-ROM drive then this is easily achieved. 

!?
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In Windows 2000/XP:
1. Click Start > Settings > Control Panel (Start >

Control Panel in XP).
2. Double-click on Administrative Tools and then

Computer Management.
3. Click on Disk Management in the left-hand panel.
4. Right-click on the drive you want to change (eg. D:)

and select Change Drive Letter and Path.
5. You can now re-assign a new letter to the drive.
In Windows 98/Me you can carry out this alteration in the
Device Manager: 
1. Right-click on My Computer and select Properties.
2. Click on the Device Manager tab, expand the

CDROM section and double-click on your CD-ROM
drive.

3. Click on the Settings tab and change the start drive
letter to the one you want to use for your CD-ROM
drive.

4. Click OK then Close and choose to restart your
computer. Your CD-ROM should now be labelled with
the new drive letter.

Recognise and Correct Autostart Problems
As well as certain keys in the registry, the Windows
Autostart folder is a common location for programs to be
placed so that they are automatically loaded when Windows
starts. Problems occur when programs are uninstalled but
fragments are left behind in Autostart, causing slow startup
or error reports while Windows is loading.
On the CD accompanying this update you will find two
programs to help you manage which programs are started
with Windows: Autoruns and Absolute Startup.

Control which
programs are
loaded when

Windows starts.

Software available
on this 

update’s CD.

!?




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Autoruns allows
you to take control
of your startup
programs.

Place a tick next
to the programs
you want to load
at startup.

Use Absolute
Startup to backup
your startup
configuration.

Autoruns
Autoruns gives you control over all of the programs that are
configured to run at system startup or login. It searches all
of the locations that Windows uses to store information
about startup programs (such as the Startup folder and Run
registry keys) and displays them in a list in the order that
Windows runs them. It has many benefits over the
MSCONFIG program that comes with Windows, such as the
ability to view all startup programs in one convenient
location.

Use Autoruns to manage startup programs

Absolute Startup
Absolute Startup allows you to manage all of the programs
which start when Windows starts. You can edit, backup and
restore your startup lists, so that you can restore a previous
configuration if you encounter problems with one of your
startup programs. You can also freeze the state of your
system startup to prevent new programs from adding
themselves. The version provided on the CD is a 21-day trial.
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Solving Windows XP Update Problems
The Windows XP update facility allows you to automatically
keep your system up-to-date by installing service packs 
and patches provided by Microsoft as they are released.
Unfortunately downloading or installing updates does not
always run smoothly. If you are experiencing error messages
when trying to update your copy of Windows, it could be
because the Cryptographic Service has become deactivated.
Reactivate it with the following steps:
1. Open Start > Control Panel.
2. Double-click on Administrative Tools and then

Services.
3. Check the Status column to ensure that the

Cryptographic Service has been started. If not right-
click on it and choose Start.

4. Your Windows Update should now work properly.

Repair Windows with its Built-in Tools
Microsoft provides many different ways to help users
configure their Windows system and troubleshoot problems.
Many of these take the form of Wizards that guide you
through the process of configuring a certain part of
Windows, but there are many hidden system utilities that
only the experts know about. 

Check incorrect system files with SFC.EXE
Does your computer crash a lot, or do you have stability
problems with some of the programs you use now and then?
These problems could be caused by a defective driver or an
error in a system file. Since Windows 2000 Microsoft have
included a special command line tool, System File Checker,
to help solve these problems. Start System File Checker by
going to S t a r t > R u n, type sfc /SCANNOW and press .Enter

Make sure
Windows Update 

is working 
properly in XP.

Use Windows
hidden tools to

repair your system.

!?


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Use System File
Checker to repair
your system.

Check your drivers
haven’t been
altered.

1.
2.
3.
4.
5.

System File Checker will scan your computer and attempt to
repair damaged system files by replacing them with the
original copies from your Windows Installation CD-ROM.
For this reason you need to have your original Windows CD
handy while running this program.

Check your device drivers with SIGVERIF.EXE
Digital signatures are a means of ensuring that a piece of
software has come from the company it claims to be from.
Microsoft has used digital signatures to verify the origin of
device drivers since Windows 98, as they can be used to
verify whether a piece of software has been altered, for
example by a virus and check for unsigned drivers in your
system.
Signatures for device drivers are produced in accordance
with the Windows Hardware Quality Labs specification.
Windows provides a program to check that the signatures of
the device drivers have not been altered. By going to Start >
Run, typing SIGVERIF.EXE then pressing you can
run the Signature Verifier.

There are many little things that can go wrong with a
complicated system like Windows that while not major are
nevertheless annoying. This article has shown you how to
master some of these problems, and make your PC sessions
much more fun and productive.

Enter


